powered by CADENAS

Manual

Manual

Chapter 5.  PARTproject

Table of Contents

5.1. Launch PARTproject
5.1.1. License selection dialog box at Floating licensing
5.2. Function
5.2.1. Opening PARTdesigner
5.2.2. License selection dialog box at Floating licensing
5.3. User interface
5.4. Project icons
5.5. Create project - Small example from A to Z
5.5.1. Step 1: Create New directory
5.5.2. Step 2: Create subfolder
5.5.3. Step 3: New project
5.5.4. Step 4: Edit project
5.5.4.1. Create geometry *.3db
5.5.4.2. Create the characteristic attribute table *.tac
5.5.4.3. Create preview image *.png
5.5.5. Step 5: Create Index
5.5.6. Step 6: Test the new project in PARTdataManager
5.5.7. Specifics for project creation in Architecture / BIM catalogs
5.6. Menus
5.6.1. File
5.6.2. Versioning system
5.6.3. ERP
5.6.4. Extras
5.6.4.1. Create offline CD
5.6.4.2. CIP catalog
5.6.4.3. Additional modules
5.6.4.3.1. Collect classification data...
5.6.4.3.2. Map class systems...
5.6.4.3.3. History Analyzer Reports
5.6.4.3.4. VDI Preview
5.6.4.4. Class systems: edit...
5.6.4.5. Class systems: export translations...
5.6.4.6. Class systems: Import translations...
5.6.4.7. Show all toolbars
5.6.4.8. Messages...
5.6.4.9. Preferences...
5.6.4.9.1. General
5.6.4.9.2. 3D view
5.6.4.9.3. Other dialog pages
5.6.5. Window
5.6.6. Help
5.7. Buttons
5.7.1. Default toolbar
5.7.1.1. Text search for part
5.7.1.2. Save
5.7.1.3. Save all Files
5.7.1.4. Update index
5.7.1.5. Fetch publication status...
5.7.2. Link database toolbar
5.8. Project selection
5.8.1. Project selection icons
5.8.2. Context menus under Project selection
5.8.2.1. Context menu of the Folder Level
5.8.2.1.1. New directory
5.8.2.1.2. New project
5.8.2.1.3. New link
5.8.2.1.4. Open Windows Explorer
5.8.2.1.5. Update view
5.8.2.1.6. Delete directory
5.8.2.1.7. Rename directory
5.8.2.1.8. Copy directory
5.8.2.1.9. Move directory
5.8.2.1.10. Hide directory / Show folder
5.8.2.1.11. Sort directory
5.8.2.1.12. Test project / Test directory
5.8.2.1.13. Translation
5.8.2.1.13.1. "Translation" tabbed page
5.8.2.1.13.1.1. Translation - Table
5.8.2.1.13.1.2. Translation - Settings / Result
5.8.2.1.13.2. "Translations" dialog window
5.8.2.1.13.3. PARTcatalogTranslator
5.8.2.1.13.4. Translation per CSV file
5.8.2.1.13.4.1. Define catalog language
5.8.2.1.13.4.2. Export CSV for translation
5.8.2.1.13.4.3. Edit CSV file
5.8.2.1.13.4.4. Import CSV for translation
5.8.2.1.13.5. Configuration of the Online Translation Services
5.8.2.1.13.5.1. Integration mode of translation service
5.8.2.1.13.5.2. Structure of configuration file
5.8.2.1.13.5.3. Google Translator - Create account
5.8.2.1.13.5.4. Microsoft Translator - Create account
5.8.2.1.14. Output
5.8.2.1.14.1. CIP catalog
5.8.2.1.14.2. Cip projects in directory
5.8.2.1.14.3. Generate image data/preview images with batch run
5.8.2.1.14.3.1. Generate previews
5.8.2.1.14.3.1.1. Launch
5.8.2.1.14.3.1.2. Preferences
5.8.2.1.14.3.1.3. Alternative: Create preview images externally and then import
5.8.2.1.14.3.2. Export images
5.8.2.1.14.3.2.1. Tabbed page "Default options"
5.8.2.1.14.3.2.2. Tabbed page "View / Export"
5.8.2.1.14.3.2.3. Tabbed page "Extended"
5.8.2.1.14.4. Create previews per line
5.8.2.1.14.5. Generate deeplinks
5.8.2.1.14.5.1. Background information on Deep Links
5.8.2.1.14.5.1.1. What are deep links?
5.8.2.1.14.5.1.2. Syntax
5.8.2.1.14.5.1.3. Parameters for PARTcommunity
5.8.2.1.14.5.1.4. Direct call to a special portal page
5.8.2.1.14.5.1.5. Force login
5.8.2.1.14.5.1.6. Showing and hiding portlets
5.8.2.1.14.5.1.7. Embedded portals
5.8.2.1.14.5.1.8. Integration of embedded portals
5.8.2.1.14.6. Write BME catalog
5.8.2.1.14.6.1. Overview
5.8.2.1.14.6.2. Command
5.8.2.1.14.6.3. Profile management
5.8.2.1.14.6.4. Create / Save
5.8.2.1.14.6.5. The dialog pages
5.8.2.1.14.6.5.1. Paths
5.8.2.1.14.6.5.2. Catalog
5.8.2.1.14.6.5.3. Price
5.8.2.1.14.6.5.4. Supplier
5.8.2.1.14.6.5.5. Buyer
5.8.2.1.14.6.5.6. Rules
5.8.2.1.14.6.5.7. Replace
5.8.2.1.14.6.5.8. Settings
5.8.2.1.14.6.5.9. Additional options
5.8.2.1.14.7. Check out projects
5.8.2.1.14.8. Check out catalog
5.8.2.1.14.9. Create CSV table
5.8.2.1.14.10. Create HTML index
5.8.2.1.14.11. Collect classification data...
5.8.2.1.14.12. History analyzer
5.8.2.1.14.13. Project dependencies
5.8.2.1.15. Automation
5.8.2.1.15.1. Start PARTinfoTool
5.8.2.1.15.2. Import eClass XML file...
5.8.2.1.15.3. Batch process all tables in project
5.8.2.1.15.3.1. Add variable / change variable value
5.8.2.1.15.3.2. Change value of variable
5.8.2.1.15.3.3. Replace variable value
5.8.2.1.15.3.4. Delete variables
5.8.2.1.15.3.5. Rename variable
5.8.2.1.15.3.6. Add variables from CSV / change variable values from CSV
5.8.2.1.15.3.7. Input options in field "Name of variable"
5.8.2.1.15.3.8. Use of keywords
5.8.2.1.15.4. Equal variables in folder
5.8.2.1.15.5. Change file information into lower case letters
5.8.2.1.15.6. Add projects to classification
5.8.2.1.15.7. Create standardization system
5.8.2.1.15.8. Create document project
5.8.2.1.15.9. Create native project
5.8.2.1.15.10. Convert previews...
5.8.2.1.15.11. Batch import neutral formats (Quick and Simple)
5.8.2.1.15.12. Materials made of colors
5.8.2.1.15.13. Add LOD Variables
5.8.2.1.15.14. Manage address data
5.8.2.1.15.15. Modify order number and type code
5.8.2.1.15.16. Batch classification of projects
5.8.2.1.15.17. Set EndOfLife per line
5.8.2.1.15.18. Reverse search ‒ Resolve check (automatic)
5.8.2.1.15.18.1. Use case
5.8.2.1.15.18.2. Process in Detail
5.8.2.1.15.18.3. User interface in detail
5.8.2.1.15.18.4. Special notes
5.8.2.1.15.18.5. Config settings
5.8.2.1.15.18.6. Reverse Search (automatic) - Avoid problematic constructs
5.8.2.1.15.19. Reverse Search – Test reverse search
5.8.2.1.15.20. Reverse TypeCode Rule Editor
5.8.2.1.15.20.1. Purpose of Editor
5.8.2.1.15.20.2. Complete process at a glance
5.8.2.1.15.20.3. Start Editor
5.8.2.1.15.20.3.1. Start Editor on "23d-libs" folder
5.8.2.1.15.20.3.2. Start editor on catalog folder
5.8.2.1.15.20.3.3. Start editor on project
5.8.2.1.15.20.3.4. Files/folder created with plugin
5.8.2.1.15.20.4. Dialog areas of Editor
5.8.2.1.15.20.4.1. Variable table
5.8.2.1.15.20.4.2. Variable values
5.8.2.1.15.20.4.3. TypeCode Tester
5.8.2.1.15.20.4.4. "Info" Docking window
5.8.2.1.15.20.4.5. Editor
5.8.2.1.15.20.4.6. Regex tester
5.8.2.1.15.20.5. Menus
5.8.2.1.15.20.5.1. "File" menu
5.8.2.1.15.20.5.2. "Edit" menu
5.8.2.1.15.20.5.3. "Tool" menu
5.8.2.1.15.20.5.4. "Settings" menu
5.8.2.1.15.20.5.5. "View" menu
5.8.2.1.15.20.6. Variable mapping
5.8.2.1.15.20.6.1. Simple variable mapping
5.8.2.1.15.20.6.2. Multiple variable mapping
5.8.2.1.15.20.6.3. Mapping empty string
5.8.2.1.15.21. VDI 3805 Importer
5.8.2.1.15.21.1. Scope of application
5.8.2.1.15.21.2. VDI Wizard
5.8.2.1.15.21.3. Expert settings
5.8.2.1.15.21.4. Precondition for operation
5.8.2.2. Context menu of the Project Level
5.8.2.2.1. Open with PARTdataManager
5.8.2.2.2. Open Explorer
5.8.2.2.3. Delete project
5.8.2.2.4. Rename project
5.8.2.2.5. Copy project
5.8.2.2.6. Move project
5.8.2.2.7. Hide project / Show project
5.8.2.2.8. Find Links
5.8.2.2.9. Test project
5.8.2.2.10. Translation
5.8.2.2.10.1. Show translations
5.8.2.2.10.2. Export CSV for translation
5.8.2.2.10.3. Import CSV for translation
5.8.2.2.11. Output
5.8.2.2.11.1. Save as CIP
5.8.2.2.11.2. Generate image data/preview images
5.8.2.2.11.3. Create previews per line
5.8.2.2.11.4. Create CSV table
5.8.2.2.11.5. Project dependencies
5.8.2.2.12. Automation
5.8.2.2.12.1. Edit project in batch mode
5.8.2.2.12.2. Add projects to classification
5.8.2.2.12.3. Add LOD Variables
5.8.2.2.12.4. Import address information
5.8.2.2.12.5. Set EndOfLife per line
5.8.2.3. Context menu of the File Level
5.8.2.3.1. Rename file
5.8.2.3.2. Open Windows Explorer
5.9. Edit project
5.9.1. Overview on tabbed pages
5.9.2. Tabbed page General
5.9.2.1. Menu item General
5.9.2.2. Menu item Assistant
5.9.2.3. Menu item Variables
5.9.2.3.1. Create variable groups (on catalog level)
5.9.2.3.2. Order/Groups of Variables - Hide columns (variables)
5.9.2.3.3. Columns to sort natural
5.9.2.3.4. Variables containing external references
5.9.2.4. Menu item Settings for the catalog (display on catalog level)
5.9.2.5. Menu item Classification
5.9.2.6. Menu item Table filters
5.9.2.7. Menu item PARTserver/PARTcommunity
5.9.2.8. Menu item Color and texture
5.9.2.8.1. Color
5.9.2.8.2. Texture
5.9.2.9. Menu item Render attributes
5.9.2.9.1. Render material - Functionality
5.9.2.9.1.1. Render Materials for Face attributes
5.9.2.9.2. Render material - Settings
5.9.2.9.3. Rendering matrices
5.9.2.9.3.1. Matrix for attributes "Color" and "Color texture" ("Normalmap")
5.9.2.9.3.2. Matrix for attributes "Percentage Metallic" and "Roughness"
5.9.2.9.3.3. Matrix for Transparency
5.9.2.9.3.4. Legend
5.9.2.9.4. Examples
5.9.2.9.5. Maxwell Render rotation
5.9.2.10. Menu item Alternative 2D size
5.9.2.11. Menu item Dimensioning
5.9.2.12. Menu item Link (display at link projects)
5.9.2.13. Menu item Expiration date (End of Life)
5.9.3. Tabbed page 3D project
5.9.3.1. Dimensioning views
5.9.3.2. 3D models
5.9.3.3. Variants
5.9.3.3.1. General concept when using variants
5.9.3.3.2. Basic notes
5.9.3.3.3. Example: Variants of Dimensioning views
5.9.3.3.4. Example: Variants of 3D models
5.9.3.3.5. Example: Specifics for project creation especially in Architecture / BIM catalogs
5.9.4. Tabbed page 2D derivation
5.9.5. Tabbed page 2D project
5.9.6. Tabbed page Bitmaps
5.9.7. Tabbed page Roller bearing
5.9.8. Tabbed page Assembly
5.9.9. Tabbed page Variable assignment (project type „Assembly Table“)
5.9.10. Tabbed page Links
5.9.10.1. Simple example without use of dialog areas Variants and Filter
5.9.10.2. Dialog area Variants (optionally)
5.9.10.3. Dialog area Filter (optionally)
5.9.10.4. Dialog area ID (optional)
5.9.11. Tabbed page Translation
5.9.12. Tabbed page Image
5.9.13. Tabbed page Database
5.9.14. Tabbed page Picture file
5.9.15. Tabbed page Table file
5.9.15.1. Set standard table row
5.9.15.2. Mark lines as expired...
5.9.16. Tabbed page Document
5.9.17. Tabbed page Documents
5.9.17.1. Media Variables for tooltip information on PARTcommunity
5.9.17.1.1. Create Media Variable
5.9.17.1.2. Translate Media Variables
5.9.17.1.3. Dialog area "Derivation hierarchy"
5.9.17.2. Media Variables for 3D PDF datasheets (PARTtemplateDesigner)
5.9.18. Tabbed page History
5.9.19. Tabbed page QA check
5.9.20. Tabbed page Catalog separation
5.9.21. Tabbed page Release Notes
5.10. Specify automatically created dimensionings (notations) for 3D view and 2D derivation
5.10.1. Example: Create dimensioning
5.10.2. Horizontal, vertical and parallel dimensioning
5.10.2.1. Mandatory parameters
5.10.2.2. Optional parameters
5.10.3. Radial dimensioning
5.10.3.1. Mandatory parameters
5.10.3.2. Optional parameters
5.10.4. Angular dimensioning
5.10.4.1. Mandatory parameters
5.10.4.2. Optional parameters
5.10.5. Annotation
5.10.5.1. Mandatory parameters
5.10.5.2. Optional parameters
5.10.6. Part-Annotation
5.10.6.1. Mandatory parameters
5.10.6.2. Optional parameters
5.10.7. Optional parameters Details
5.10.7.1. Correct display of inch variables in dimensionings
5.10.8. 3D Parameter
5.10.9. Using variables
5.10.10. PARTdesigner Expressions
5.11. Adjust 2-D derivations
5.11.1. 2D derivation: Alternative 2D size (shortened)
5.11.1.1. Function
5.11.1.2. Configuration
5.11.1.3. Example
5.11.2. 2D derivation: Enhance Default views
5.11.2.1. Create New 2D drawing
5.11.2.1.1. Create drawing
5.11.2.1.2. Save drawing
5.11.2.2. Allocate 2D derivation in PARTproject
5.11.2.3. Display in the PARTdataManager
5.11.2.4. Export into CAD system
5.11.2.5. Add dimensioning directly before transferring to PARTdataManager
5.11.2.6. BMG Layer (DIN4003)
5.11.3. 2D derivation: Create your own Combination views (*.dw)
5.11.3.1. Basics
5.11.3.2. Edit Combination views in Edit mode
5.11.3.3. [Template] with basic information
5.11.3.4. [Description] for display name
5.11.3.5. [ELEMENT_grid] to place several derivations
5.11.3.6. [ELEMENT_box] as wildcard element
5.11.3.7. [ELEMENT_derivation] for one single derivation
5.11.3.8. [ELEMENT_text] Text
5.11.3.9. [ELEMENT_table] Table
5.11.3.10. [ELEMENT_frame] Combine more elements in frame
5.11.3.11. [Formats] Different paper formats
5.11.3.12. Translations
5.11.3.13. DW files per table line
5.12. Create Dimensioning views (Technical details)
5.12.1. Create Dimensioning views with PARTdesigner
5.12.1.1. Select *.3db object
5.12.1.2. Dimensioning *.3db Object
5.12.2. External creation and import/conversion of Dimensioning views
5.12.3. Image-table connection
5.13. Classify
5.13.1. Why classifying?
5.13.2. Overview matrix
5.13.3. Classifications
5.13.3.1. Classification (CNS)
5.13.3.1.1. Class "CNSGEOMBASE" -> Feature "CNS_NOSECTION"
5.13.3.1.2. Class "CNSERPBASE" -> Feature "CNS_RAWMATERIAL"
5.13.3.1.3. Class "CNSERPBASE" -> Feature "CNSCERTIFICATEROHS"
5.13.3.2. Classification (By Categories) - (By Countries) - (By Alphabet)
5.13.3.3. Classification (Delivery countries)
5.13.3.4. Classification (Standards)
5.13.4. Simple assigning of important variables to CNS classification
5.13.5. Add projects to classification
5.13.5.1. Assignment of classifications and attributes
5.13.5.1.1. Assignment of classes and attributes at project level
5.13.5.1.1.1. Allocate class
5.13.5.1.1.2. Assign Attributes
5.13.5.1.2. Assignment of classifications and attributes at directory level
5.13.5.1.2.1. Manual Input
5.13.5.1.2.2. Automatic take-over
5.13.5.1.2.3. Use classification from project
5.13.5.2. Index update
5.13.5.3. Classifying own parts
5.13.5.3.1. Value take-over from the Measure dialog window
5.13.5.4. Classify connection points
5.13.6. Batch classification of projects
5.13.7. Create Published elements
5.13.7.1. Published elements - Choose connection point
5.13.7.2. Published elements - Choose connection points via formula
5.13.7.3. Published elements - Select sketch
5.13.7.4. Published elements - Select plane
5.13.7.5. Published elements - Select Face
5.13.8. Classify standard parts for placement dialog
5.13.9. Classify threaded connections (own company standards)
5.13.9.1. Connection points at threaded connections
5.13.10. Classify Electrical Parts
5.13.10.1. Align component
5.13.10.1.1. Set Connection point
5.13.10.1.2. Classify Connection point
5.13.10.1.3. General notes regarding part and axis orientation
5.13.10.1.3.1. Project creation
5.13.10.1.3.2. Axes orientation at Q&S import
5.13.10.1.3.3. Manipulation of axes orientation (PARTproject) and part orientation (PARTdesigner)
5.13.10.2. Classification according to IEC Code 81346_2
5.13.10.3. Classification of Electrical Connections [CNS_CP|4|3])
5.13.10.3.1. Classify a terminal - whole procedure
5.13.10.3.2. Connections, Function groups, IEC symbols
5.13.10.3.2.1. Connections, function groups, IEC symbols in eCl@ss
5.13.10.3.2.1.1. Connections in eCl@ss Advanced
5.13.10.3.2.1.2. Physical connection properties
5.13.10.3.2.1.3. Functions(groups): logical connection properties
5.13.10.3.2.1.4. IEC symbols
5.13.10.3.3. Classify "Equivalent potentials"
5.13.10.3.4. Classification of connectors
5.13.10.3.4.1. Classification: Connectors excluded frames
5.13.10.3.4.1.1. Global classification: Symbol MasterSymbol BlockSymbol (CNSELEK|4)
5.13.10.3.4.2. Classification of frames
5.13.10.4. Classify Mounting Points (Mounting Point [CNS_CP|4|6] and Mounting Description [CNS_CP|4|7])
5.13.10.5. Classification of cables
5.13.10.5.1. Overview on CNS cable classification
5.13.10.5.2. Definition of the single cable elements in linear form
5.13.10.5.3. Recursive hierarchical connection of single cable elements
5.13.10.5.4. Import of existing cable classifications
5.13.10.6. Accessory parts (Associated Part [CNSELEK|5|4])
5.13.10.6.1. Accessory parts in eClass Advanced
5.13.10.6.1.1. Set links to accessory parts in PARTsolutions
5.13.10.7. General rules
5.13.10.7.1. Conditional connection points
5.13.10.7.2. Classify by using a prefix or regular expression
5.13.10.7.3. Simple Assemblies
5.13.10.8. Additional information
5.13.10.9. Provided CNS classes
5.13.10.10. Mapping between eCl@ss and CNS classification
5.13.10.11. Additional modules
5.13.10.11.1. Connection Point Wizard
5.13.10.11.2. Electrical classification import/export
5.13.10.12. Classification certification levels
5.13.10.12.1. BMEcatIdentifier - Component Type - Certification level
5.13.10.13. Classify Electrical Parts - Tutorial
5.13.10.13.1. Connection points in general
5.13.10.13.1.1. Conditional connection points
5.13.10.13.1.2. Classify by using a prefix or regular expression
5.13.10.13.1.2.1. Classify a number of connection points in the same way
5.13.10.13.1.2.2. Classify groups of patterns
5.13.10.13.2. Defining the device orientation
5.13.10.13.3. Device type determination
5.13.10.13.3.1. Classify device type according to eClass
5.13.10.13.3.2. Classify device type according to CNS classification -> IEC Code 81346_2
5.13.10.13.4. Set Electrical Connections (CNS_CP|4|3) exemplified with a terminal
5.13.10.13.5. Class "Electrical Connection" (CNS_CP|4|3) -> Attribute "Connection EclassSymbolMap"
5.13.10.13.6. Class "Electrical Connection" (CNS_CP|4|3) -> Attribute "Connection Name Equivalences"
5.13.10.13.7. Particularities at connectors
5.13.10.13.7.1. Unique "Identifier"
5.13.10.13.7.2. Connector Symbol (CNSELEK|4)
5.13.10.13.7.3. Frames
5.13.10.13.8. Mounting Description (CNS_CP|4|7)
5.13.10.13.9. Mounting Point (CNS_CP|4|6)
5.13.10.13.10. Associated Part [CNSELEK|5|4]
5.13.10.13.11. Test in PARTdataManager
5.13.10.13.12. Most frequent error sources
5.13.10.13.12.1. Error source 1 - Missing global symbol
5.13.10.13.12.2. Error source 2 - Missing or wrong internal references
5.13.10.13.12.3. Error source 3 - Wrong configuration of interface
5.13.11. Classification for GAEB (Public tender texts)
5.13.12. Apply own Class system
5.13.12.1. Call
5.13.12.2. Create class system
5.13.12.3. Edit class system
5.13.12.3.1. Building/editing class system
5.13.12.3.2. Create / edit attributes
5.13.12.4. Classify part / edit attributes
5.13.12.4.1. Index update
5.13.12.4.2. Assign class
5.13.12.4.3. Edit attributes
5.13.12.4.4. Index update
5.13.12.5. Own classes in PARTdataManager
5.13.12.5.1. Selection via "Classes" tabbed page
5.13.12.5.2. Part information
5.13.12.5.3. Show class variables in the column header of the table
5.13.12.6. Class systems: export translations...
5.13.12.7. Class systems: Import translations...
5.13.13. Map class systems...
5.13.13.1. Overview
5.13.13.2. Create new mapping
5.13.13.2.1. Configure mapping strategy
5.13.13.2.1.1. Levenshtein strategy
5.13.13.2.1.2. eClass upgrade strategy
5.13.13.3. Edit mapping
5.13.13.4. Map class systems: Example
5.13.14. Collect classification data...
5.14. Create catalogs - Quick & Simple
5.14.1. Licensing issues
5.14.2. Prepare catalog data (provided by customer as standard)
5.14.3. Import data / Create catalog
5.14.4. Settings via configuration file
5.14.5. Post-processing
5.15. Embed use cases in PARTdataManager / PARTcommunity
5.16. Tips and Tricks
5.16.1. Rename variables

In this chapter you will find a detailed description of the individual functions and comprehensive subjects.