powered by CADENAS

Manual

Manual

Chapter 7.  PARTdesigner parametric tool

Table of Contents

7.1. Function
7.2. Calling PARTdesigner
7.3. User interface
7.4. Create 3D model: Small example from A to Z
7.5. Create table: Small example from A to Z
7.6. 3D History docking window
7.6.1. What are Features?
7.6.2. Part (name) context menu
7.6.2.1. Identification data...
7.6.2.2. Insert Fixed plane...
7.6.2.3. Exchange base planes (part)
7.6.2.4. Import foreign geometries
7.6.2.5. Dependencies... (part)
7.6.2.6. Search
7.6.2.7. Rotate (part)
7.6.2.8. Pan (part)
7.6.2.9. Mirror
7.6.3. Context menu base plane (Plane XY, ZX, YZ)
7.6.3.1. Properties... (base plane)
7.6.3.2. New sketch... (base plane)
7.6.3.3. New 2D drawing... (base plane)
7.6.3.3.1. Buttons in connection with New 2D drawing
7.6.3.3.1.1. Text
7.6.3.3.1.2. Polyline
7.6.3.3.1.3. ellipses
7.6.3.3.1.4. Insert hatch
7.6.3.3.1.5. Dimensioning mode
7.6.3.4. Dependencies... (Plane Feature)
7.6.3.5. Insert new plane... (Plane Feature)
7.6.3.6. Delete plane (Plane Feature)
7.6.3.7. Visible (Plane Feature)
7.6.3.8. Paste sketch
7.6.4. Sketch context menu
7.6.4.1. Edit...
7.6.4.2. Base
7.6.4.2.1. Extrude...
7.6.4.2.2. Rotate...
7.6.4.3. Cut
7.6.4.3.1. Extrude...
7.6.4.3.2. Rotate...
7.6.4.4. Copy (only sketch)
7.6.4.5. Cut (including dependencies) - Move complete history tree
7.6.4.6. Rename
7.6.4.7. Delete...
7.6.4.8. Show error...
7.6.4.9. Dependencies...
7.6.4.10. Duplicate sketch
7.6.4.11. Construction sketch
7.6.4.12. Set mark
7.6.5. Extrusion and/or rotation feature context menu
7.6.5.1. Edit... (Base extrusion / Cut extrusion)
7.6.5.2. Select all surfaces
7.6.5.3. Rename... (Base extrusion / Cut extrusion)
7.6.5.4. Delete... (Base extrusion / Cut extrusion)
7.6.5.5. Show error... (Base extrusion / Cut extrusion)
7.6.5.6. Dependencies... (Extrusion feature)
7.6.5.7. Convert to cut / Convert to base
7.6.5.8. Set mark
7.6.6. Level of detail
7.7. 3D view docking window
7.7.1. Face attributes
7.7.1.1. Assign face attributes
7.7.1.2. Set face attributes to several faces at once
7.7.1.3. Texture and color changes for whole part
7.7.1.4. Edit / display attributes already used in the Face class browser
7.7.1.5. Face attributes
7.7.1.6. The individual Face attributes
7.7.1.6.1. Color (SYS_FaceAttributeColor)
7.7.1.6.2. Layer (SYS_FaceAttributeLayer)
7.7.1.6.3. Render material (SYS_FaceAttributeRenderMaterial)
7.7.1.6.4. Text (SYS_FaceAttributeText)
7.7.1.6.4.1. CAD text attribute on face
7.7.1.6.4.2. HTML text attribute on face
7.8. Variable Manager docking window
7.8.1. Variable Manager - The most important at a glance
7.8.2. Create new variable
7.8.3. Change variable value
7.8.4. Rename variable
7.8.5. Delete variable
7.8.6. Sort variables (in characteristic attribute table)
7.8.7. Mark dependent elements
7.8.8. Replace with content
7.8.9. Variable Manager - The individual parameters
7.8.10. Save location: Only in geometry | Only in table | In geometry and table
7.8.10.1. Unknown variable (Error message)
7.8.10.2. Using mathematical function in Sketch or Attribute algorithm?
7.8.11. Attribute algorithms
7.8.11.1. Mathematical functions (Attribute algorithm)
7.8.11.2. Translation functions
7.8.12. Value ranges
7.8.12.1. Type "Value range variable"
7.8.12.2. Type "Value range variable with naming"
7.8.12.3. Type "Value range variable with graphics"
7.8.12.4. Type "Value range variable" in combination with IF condition (attribute algorithm)
7.8.12.4.1. IF condition: Simple example
7.8.12.4.2. IF condition: Value range variable controlled by other
7.8.13. Identification type
7.9. Sketcher docking window
7.9.1. Overview of user interface
7.9.2. Launching the Sketcher
7.9.2.1. Create new sketch
7.9.2.2. Edit sketch
7.9.3. Function buttons
7.9.3.1. Basics for use
7.9.3.2. Point
7.9.3.2.1. Connection points for assembly construction
7.9.3.2.1.1. Connection points in general
7.9.3.2.1.2. Name conventions for Connection points and Insertion lines
7.9.3.2.1.3. Direction of connection points
7.9.3.2.1.4. Connection points at miters
7.9.3.2.1.5. Connection points at connection elements
7.9.3.2.1.6. Create Connection line
7.9.3.2.2. Create pattern
7.9.3.2.2.1. Create pattern with linear alignment
7.9.3.2.2.2. Create rotated pattern
7.9.3.2.2.3. Irregular patterns
7.9.3.2.2.4. Using face attributes for patterns
7.9.3.2.3. Sweep
7.9.3.2.4. Connection points as Published elements for automatic placement in the CAD
7.9.3.3. Lines
7.9.3.3.1. Line through 2 points
7.9.3.3.2. Create parallel line
7.9.3.3.3. Perpendicular to line through point
7.9.3.3.4. Midpoint perpendicular to line
7.9.3.3.5. Bisect angle between 2 lines
7.9.3.3.6. Line at angle to line with length
7.9.3.3.7. Line at angle to horizontal, length
7.9.3.3.8. Horizontal line
7.9.3.3.9. Vertical line
7.9.3.3.10. Line tangent to 2 circles
7.9.3.3.11. Tangent from point to circle
7.9.3.4. N-edge
7.9.3.5. Circle
7.9.3.6. Arc
7.9.3.7. Delete
7.9.3.8. Transform
7.9.3.8.1. Move selection
7.9.3.8.2. Mirror selection
7.9.3.8.3. Rotate selection
7.9.3.8.4. Matrix copy
7.9.3.8.5. Variant copy
7.9.3.9. Attributes
7.9.3.10. Edit existing geometry
7.9.3.10.1. Insert Chamfer/Fillet... with Blend feature
7.9.3.10.1.1. What is the purpose of the Blend Feature
7.9.3.10.1.2. What is NOT the purpose of the Blend Feature
7.9.3.10.1.3. Basics - Create chamfer or fillet
7.9.3.10.1.4. General tips & notes
7.9.3.10.1.5. What should be considered
7.9.3.10.1.5.1. All blends, whose edges meet, have to be made as one blend
7.9.3.10.1.5.2. Blends in pattern
7.9.3.10.1.5.3. Tangent continuous
7.9.3.10.1.5.4. Preview presentation for Chamfer/Fillet
7.9.3.10.1.5.5. Face selection
7.9.3.10.1.5.6. Combination of Sweep and Blend
7.9.3.10.1.5.7. Depiction of Chamfer/Fillet in different CAD systems
7.9.3.10.1.6. Not supported installation situations
7.9.3.10.1.6.1. Function "Generate sketch on selected face" needs at least one edge without Blend
7.9.3.10.1.6.2. Several intersecting chamfers/fillets and Blend feature in addition
7.9.3.10.1.6.3. Edges resulting from Blends
7.9.3.10.1.6.4. Maximum radius of Chamfer/Fillet
7.9.3.10.1.6.5. Blends whose edges meet with different size each
7.9.3.10.1.6.6. Combination of a fillet and a chamfer
7.9.3.10.1.6.7. Radius of chamfer/fillet larger than distance to adjoining geometry
7.9.3.11. Threads
7.9.3.11.1. Cylindrical thread by length
7.9.3.11.1.1. Outer thread with example pin
7.9.3.11.1.1.1. Regular thread
7.9.3.11.1.1.2. Different pitches and derived automatic calculations for e.g. Row Label and Core diameter
7.9.3.11.1.2. Inner thread using the example of a cap nut
7.9.3.11.2. Conical thread by lengths
7.9.3.11.2.1. Regular thread
7.9.3.12. Text
7.9.3.13. File management
7.9.3.13.1. *.dbs-, *.skt bzw. *.hsk files - "Insert sketch" window
7.9.3.13.2. Window „DXF Import“
7.9.4. Sketch history
7.9.5. Context menus of Sketch history
7.9.5.1. Change parameter
7.9.5.2. Rotation axis
7.9.5.3. Delete step
7.9.5.4. Mark dependent elements
7.9.5.5. Delete step include dependent elements
7.9.6. Mathematical functions (Sketch)
7.9.7. Problem avoidance
7.10. 2D derivation docking window
7.11. Table docking window
7.11.1. Add row
7.11.2. Delete row
7.11.3. Duplicate row
7.11.4. Move row up
7.11.5. Move row down
7.11.6. Debugger
7.11.7. Cursor movement up or down
7.11.8. Cut
7.11.9. Copy
7.11.10. Paste
7.11.11. Overwrite
7.11.12. Delete
7.11.13. Show/hide value range columns
7.11.14. Show/hide columns with attribute algorithms
7.11.15. Save as CSV file
7.11.16. Import CSV file
7.11.17. Show variable dependencies
7.11.18. Sort
7.11.19. Fill columns
7.12. File management
7.12.1. New
7.12.2. New table
7.12.3. Open
7.12.4. Save or Save as...
7.12.5. Save as CSV file
7.12.6. Import CSV file
7.12.7. Identification data
7.12.7.1. Geometry
7.12.7.2. Table
7.12.7.3. Guideline for NB, SHORTNB, LINA definition and Identification type
7.12.8. Recent parts
7.12.9. Close
7.13. View menu
7.14. Extras menu
7.14.1. Resolve value ranges...
7.14.2. Sort
7.14.3. Physical properties of the part
7.14.4. Settings...
7.14.4.1. PARTdesigner menu item
7.14.4.2. Sketcher (feat.) menu item
7.14.4.2.1. Color settings
7.14.4.2.2. Performance
7.14.4.2.3. Grid
7.14.4.2.4. Shortcuts
7.14.4.3. Formula optimizer tabbed page
7.14.4.4. Other menus
7.15. Window menu
7.16. Help menu (?)
7.17. More functions
7.17.1. Export
7.17.1.1. Case 1 - Export 3D part to 3D CAD system
7.17.1.2. Case 2 - Export 3D part to 2D CAD system
7.17.2. Automatic recalc on/off
7.17.3. Test part
7.17.4. Search
7.18. License selection dialog box at Floating licensing

PARTdesigner

PARTdesigner