powered by CADENAS

Manual

Manual

7.3. User interface

The user interface is subdivided into toolbar, menu bar and docking windows:

Menu bar

At the top you can find the following menus:

Toolbar

Under the menu bar you can find Standard and Export toolbar with following buttons:

Docking windows

The main view consists of single docking windows.

PARTdesigner with 3D History, 3D view, Variable Manager and Table

PARTdesigner with 3D History, 3D view, Variable Manager and Table

PARTdesigner with Sketch history, Sketcher, Variable Manager, Table and 3D view

PARTdesigner with Sketch history, Sketcher, Variable Manager, Table and 3D view

You can solve them like in PARTdataManager and move to another monitor.

[Note] Note

The above figures show the default view, once with 3D History and once with Sketch history and Sketcher.

  • Show or hide single docking windows via the respective buttons of the Default toolbar or menu items of the View menu.

    Default toolbar

    Default toolbar

    • 3D History

    • 3D view

    • Sketcher

      (with Sketch history)

    • Variable Manager

    • Table

    • 2D derivation

    View menu

    View menu

  • Move the single docking windows and adjust them in size. A detailed description on this can be found under Section 3.1.5.4, “Placing method for dockings ” in PARTsolutions / PARTcommunity4Enterprise - User manual.

In the following you will get a short overview on the single docking windows (working areas) with a link to the respective chapter:

  • 3D History

    The docking window 3D History is a central "arena" within PARTdesigner. Via its context menus, the Sketcher (with Sketch history) is opened and the part created.

    Calling the Sketcher via 3D History

    Calling the Sketcher via 3D History

    In the Sketch history all design steps are documented, so that you can retrace later how a part is assembled and possibly modify a step. When calling a new file at first the feature tree only shows the three Base levels XY, ZX, YZ. All other design steps (sketches, rotations, extrusions, etc.) are then listed below.

    The button or the respective menu item open the docking window 3D History or bring it into the foreground.

    Detailed information on 3D History can be found under Section 7.6, “ 3D History docking window ”.

  • Sketcher

    A 3D solid must basically be created via a 2D sketch. This 2D sketch is created in the Sketcher dialog area.

    Here, through individual design steps, the sketches are created, which later then create the basis for extrusions and rotations in the 3D History dialog area.

    The button Sketcher or the respective menu item open the respective docking window Sketcher and Sketch history or bring them into the foreground.

    Detailed information on the Sketcher can be found under Section 7.9, “ Sketcher docking window ”.

  • 3D view

    [Note] Note

    The 3D view is identical to the depiction in the Part view of PARTdataManager .

    The button 3D window or the respective menu item open the docking window 3D view or bring it into the foreground.

    Detailed information on 3D view can be found under Section 7.7, “ 3D view docking window ”.

  • Variable Manager

    In PARTdesigner, instead of fixed dimensioning values, variables are created, which are filled by concrete values from the characteristic attribute table. This method has the advantage that a new sketch must not be made for each part value (characteristic).

    In the docking window Variable Manager, you can create new variables or change already existing variables.

    The button Variable Manager or the respective menu item open the docking window Variable Manager or bring it into the foreground.

    Detailed information on the Variable Manager can be found under Section 7.8, “ Variable Manager docking window ”.

  • Table

    [Note] Note

    The Table is identical to the depiction in the Part view of PARTdataManager.

    The button Table window or the respective menu item open the docking window Table or bring it into the foreground.

    When changing a table line or a value range value, the respective characteristic in the docking window 3D view, Sketcher or 2D derivation is automatically visualized.

    When starting PARTdesigner via 3db file, the table is displayed in the lower area of PARTdesigner by default (compare Fig. „PARTdesigner with 3D History, 3D view, Variable Manager and Table “). This view is used as well, if inside PARTdesigner, via File menu -> Open a prj- or 3db file is opened.

    When starting PARTdesigner via tab/tac file, the table gets a large area beside Variable Manager. This view is used as well, if inside PARTdesigner, via File menu -> Open, a tab/tac file is opened.

    Detailed information on Table can be found under Section 7.11, “ Table docking window ”.

  • The button 2D derivation or the respective menu item open the docking window 2D derivation or bring it into the foreground.

    In order to display the solid body of the 3D view in 2D mode, please choose a perspective (Front, Back, Right, Left, Top, Bottom) or view under Default views or Combination views.

    Also see Section 7.10, “ 2D derivation docking window ”.

    Details on 2D view in PARTdataManager can be found under Section 13.2, “ Create 2D derivation ”.