powered by CADENAS

Manual

Manual

7.5. Create table: Small example from A to Z

In the following a simple characteristic attribute table shall be created.[61]

Proceed as follows:

  1. In PARTproject, create a new project. A small example on this can be found under Section 5.5, “Create project - Small example from A to Z ”.

    In the project to be edited, select the *.tab or *.tac file.

    Click on Edit.

    PARTdesigner opened via tab file

    PARTdesigner opened via tab file

    --> PARTdesigner is opened in the table view.

    PARTdesigner - Table view

    PARTdesigner - Table view

    In the table view, the docking window Variable Manager is opened together with the docking window Table by default.

    [Note] Note
    • If needed, show/hide single docking windows via respective buttons of the Default toolbar or menu items in the View menu.

      Default-Toolbar

      Default-Toolbar

      • 3D History

      • 3D view

      • Sketcher

        (with Sketch history)

      • Variable Manager

      • Table

      • 2D derivation

      View menu

      View menu

    • Move single docking windows or adjust them in size. A detailed description on the placing method can be found under Section 3.1.5.4, “Placing method for dockings ” in PARTsolutions / PARTcommunity4Enterprise - User manual.

  2. In the Variable Manager, create the variables L (Length), W (Width) and H (Height) for a cuboid. Details on the Variable Manager can be found under Section 7.8, “ Variable Manager docking window ”.

    1. Under Save location the option Only in table is already selected since PARTdesigner has been opened via tab file.

      Using this option all input fields are active. Details on the individual parameters can be found under Section 7.8.9, “ Variable Manager - The individual parameters”.

      For starters orient by the following figure.

      Here H (height) with value 10 has been entered.

      Here H (height) with value 10 has been entered.

    2. Confirm by clicking Commit.

    3. For each variable, create a new line by clicking .

    --> Once after creation of a variable in the Variable Manager, it is also displayed in the table.

    Variables H, L and W created

    Variables H, L and W created

  3. Add other characteristics by clicking Add row .

  4. Click Save .

    -> The dialog box Identification data is opened with tabbed page Table. Fill out the mandatory fields Standard name, Description for BOM, Standard number and Standard title. Details on this can be found under Section 7.12.7, “ Identification data ”.

    Dialog box "Identification data" - Tabbed page "Table"

    Dialog box "Identification data" - Tabbed page "Table"

    The dialog box can be opened via File menu -> Identification data or via anytime.

    Confirm with OK.

    [Note] Note
    • Pay attention on the used syntax in the field Standard name.

    • The dialog box Identification data can only be closed via OK, when all mandatory fields are filled out.

After finishing the table, in the next step the 3D model is created.

  1. Therefor, open the 3db file from PARTproject. The variables are automatically overtaken from the related (same-named) tab/tac file.

  2. For all variables to be used in the sketch, under Save location, select the option In geometry and table. Details on this can be found underSection 7.8.10, “ Save location: Only in geometry | Only in table | In geometry and table ”.[62]

    Otherwise the error message Unknown variable is displayed.

  3. Create the 3D model based on the created variables. A small example on this can be found under Section 7.4, “Create 3D model: Small example from A to Z ”.



[61] The corresponding example can be found in the Training catalog under \v11_news\starting_point_table_or_sketch\cuboid.prj.

[62] The color code signalizes in which mode a variable is saved.

  • Table variable

  • Table variable and designer variable

  • Designer variable