powered by CADENAS

Manual

Manual

7.3. Benutzeroberfläche

Die Benutzeroberfläche gliedert sich in folgende Bereiche:

Ganz oben findet sich die Menüleiste mit den Menüs Datei, Ansicht, Extras und Hilfe, darunter die Standard-Toolbar mit Buttons insbesondere für das Dateimanagement, die Steuerung der Dockingfenster (ein/aus) und den Export.

PARTdesigner mit 3D Historie, 3D Ansicht, Variablenmanager und Tabelle

PARTdesigner mit 3D Historie, 3D Ansicht, Variablenmanager und Tabelle

PARTdesigner mit Sketch Historie, Sketcher, Variablenmanager, Tabelle und 3D Ansicht

PARTdesigner mit Sketch Historie, Sketcher, Variablenmanager, Tabelle und 3D Ansicht

Die Hauptansicht ist zusammengesetzt aus einzelnen Dockingfenstern. Sie können diese wie in PARTdataManager lösen und gegebenenfalls auch auf einen anderen Monitor verschieben.

[Hinweis] Hinweis

Die beiden obigen Abbildungen zeigen die Default-Ansicht einmal mit 3D Historie und einmal mit Sketch Historie und Sketcher.

  • Blenden Sie über die entsprechenden Buttons der Standard-Toolbar oder die Menüpunkte im Ansicht-Menü einzelne Dockingfenster ein- und aus.

    Standard-Toolbar

    Standard-Toolbar

    • 3D Historie

    • 3D-Ansicht

    • Sketcher

      (mit Sketch Historie)

    • Variablenmanager

    • Tabelle

    • 2D-Ableitung

    Ansicht-Menü

    Ansicht-Menü

  • Verschieben Sie die einzelnen Dockingfenster und passen Sie diese in der Größe an. Eine detaillierte Beschreibung zur Platzierungsmethode finden Sie unter Abschnitt 3.1.5.4, „Platzierungsmethode für Dockingfenster“ in PARTsolutions / PARTcommunity4Enterprise - Handbuch für Anwender.

Im Folgenden finden Sie eine Kurzübersicht zu den einzelnen Dockingfenstern mit Link auf das entsprechende Kapitel:

  • 3D Historie

    Das Dockingfenster 3D Historie ist ein zentraler „Schauplatz“ innerhalb des PARTdesigner. Über seine Kontextmenüs wird der Sketcher (mit Sketch Historie) aufgerufen und das Bauteil erstellt.

    Aufruf des Sketchers über die 3D Historie

    Aufruf des Sketchers über die 3D Historie

    In der Sketch Historie werden sämtliche Konstruktionsschritte dokumentiert, sodass der jeweilige Bauteilaufbau auch später nachvollzogen und eventuell modifiziert werden kann. Beim Aufruf einer neuen Datei zeigt der Feature-Baum lediglich die drei Basisebenen XY, ZX, YZ an. An die Ebenen fügen sich alle weiteren Konstruktionsschritte (Skizzen, Rotationen, Extrusionen, etc.) an.

    Die Schaltfläche bzw. der entsprechende Menüpunkt öffnen das Dockingfenster 3D Historie bzw. bringen es in den Vordergrund.

    Detaillierte Informationen zur 3D Historie finden Sie unter Abschnitt 7.6, „3D Historie Dockingfenster“.

  • Sketcher

    Ein 3D-Festkörper muss grundsätzlich über einen 2D-Sketch erzeugt werden. Dieser 2D-Sketch wird im Dialogbereich Sketcher erstellt.

    Hier werden in einzelnen Konstruktionsschritten die Zeichnungen erstellt, welche wiederum im Dialogbereich 3D Historie die Basis für Extrusionen und Rotationen bilden.

    Die Schaltfläche Sketcher bzw. der entsprechende Menüpunkt öffnen die Dockingfenster Sketcher und Sketch Historie bzw. bringen sie in den Vordergrund.

    Detaillierte Informationen zum Sketcher finden Sie unter Abschnitt 7.9, „Sketcher Dockingfenster“.

  • 3D Ansicht

    [Hinweis] Hinweis

    Die 3D-Ansicht entspricht der Darstellung in der Teileansicht des PARTdataManager.

    Die Schaltfläche 3D Fenster bzw. der entsprechende Menüpunkt öffnen das Dockingfenster 3D-Ansicht bzw. bringen es in den Vordergrund.

    Detaillierte Informationen zur 3D Ansicht finden Sie unter Abschnitt 7.7, „3D-Ansicht Dockingfenster“.

  • Variablenmanager

    Im PARTdesigner werden - anstelle von festen Bemaßungswerten - Variablen eingerichtet, für die in Tabellen konkrete Werte hinterlegt sind. Diese Methode hat den Vorteil, dass nicht für jede Bauteilausprägung eine eigene Zeichnung erstellt werden muss.

    Im Dockingfenster Variablenmanager können Sie neue Variablen anlegen bzw. Angaben zu vorhandenen Variablen ändern.

    Die Schaltfläche Variablen Manager bzw. der entsprechende Menüpunkt öffnen das Dockingfenster Variablenmanager bzw. bringen es in den Vordergrund.

    Detaillierte Informationen zum Variablenmanager finden Sie unter Abschnitt 7.8, „Variablenmanager Dockingfenster“.

  • Tabelle

    [Hinweis] Hinweis

    Die Tabelle entspricht der Darstellung in der Teileansicht des PARTdataManager.

    Die Schaltfläche Tabellenfenster bzw. der entsprechende Menüpunkt öffnen das Dockingfenster Tabelle bzw. bringen es in den Vordergrund.

    Durch Änderung einer Tabellenzeile oder eines Wertebereichs wird automatisch die entsprechende Ausprägung im Dockingfenster 3D Ansicht, Sketcher oder 2D-Ableitung visualisiert.

    Wird PARTdesigner über die 3db-Datei gestartet, erscheint die Tabelle standardmäßig im unteren Bereich von PARTdesigner (vgl. Abb. „PARTdesigner mit 3D Historie, 3D Ansicht, Variablenmanager und Tabelle“). Diese Ansicht wird ebenfalls verwendet, wenn innerhalb von PARTdesigner mittels Datei-Menü -> Öffnen eine prj- oder 3db-Datei geöffnet wird.

    Wird PARTdesigner über die tab/tac-Datei gestartet, bekommt die Tabelle standardmäßig einen großen Bereich. Diese Ansicht wird ebenfalls verwendet, wenn innerhalb von PARTdesigner mittels Datei-Menü -> Öffnen eine tab/tac-Datei geöffnet wird.

    Detaillierte Informationen zur Tabelle finden Sie unter Abschnitt 7.11, „Tabelle Dockingfenster“.

  • Die Schaltfläche 2D-Ableitung bzw. der entsprechende Menüpunkt öffnen das Dockingfenster 2D-Ableitung bzw. bringen es in den Vordergrund.

    Um sich den Volumenkörper aus der 3D-Ansicht im 2D-Modus anzeigen zu lassen, wählen Sie bitte eine Perspektive (Vorne, Hinten, Rechts, Links, Oben, Unten) bzw. Ansicht unter Standardansichten oder Kombinationsansichten aus.

    Siehe auch Abschnitt 7.10, „2D-Ableitung Dockingfenster“.

    Details zur 2D-Ansicht im PARTdataManager finden Sie unter Abschnitt 13.2, „2D-Ableitung erzeugen“.