powered by CADENAS

Manual

Manual

7.5. Tabelle erstellen: Kleines Beispiel von A bis Z

Im Folgenden soll in Kurzfassung eine Sachmerkmalstabelle erstellt werden.[61]

Gehen Sie hierbei folgendermaßen vor:

  1. Legen Sie in PARTproject ein neues Projekt an. Ein kleines Beispiel hierzu finden Sie unter Abschnitt 5.5, „Projekt anlegen - Kleines Beispiel von A bis Z“.

    Markieren Sie im zu bearbeitenden Projekt die *.tab bzw. *.tac Datei.

    Klicken Sie auf Bearbeiten.

    PARTdesigner über tab-Datei öffnen

    PARTdesigner über tab-Datei öffnen

    --> PARTdesigner wird in der Tabellenansicht geöffnet.

    PARTdesigner Tabellenansicht

    PARTdesigner Tabellenansicht

    Das Dockingfenster Variablenmanager wird in der Tabellenansicht standardmäßig zusammen mit dem Dockingfenster Tabelle geöffnet.

    [Hinweis] Hinweis
    • Blenden Sie bei Bedarf über die entsprechenden Buttons der Standard-Toolbar oder die Menüpunkte im Ansicht-Menü einzelne Dockingfenster ein- und aus.

      Standard-Toolbar

      Standard-Toolbar

      • 3D Historie

      • 3D-Ansicht

      • Sketcher

        (mit Sketch Historie)

      • Variablenmanager

      • Tabelle

      • 2D-Ableitung

      Ansicht-Menü

      Ansicht-Menü

    • Verschieben Sie die einzelnen Dockingfenster und passen Sie diese in der Größe an. Eine detaillierte Beschreibung zur Platzierungsmethode finden Sie unter Abschnitt 3.1.5.4, „Platzierungsmethode für Dockingfenster“ in PARTsolutions / PARTcommunity4Enterprise - Handbuch für Anwender.

  2. Legen Sie im Variablenmanager für einen Quader die Variablen L (Length), W (Width) und H (Height) an. Details zum Variablenmanager finden Sie unter Abschnitt 7.8, „Variablenmanager Dockingfenster“.

    1. Unter Speicherort ist bereits die Option Nur in Tabelle ausgewählt, da PARTdesigner über die tab-Datei geöffnet wurde.

      Bei dieser Option sind alle Eingabefelder aktiv. Details zu den einzelnen Parametern finden Sie unter Abschnitt 7.8.9, „Variablenmanager - Die einzelnen Parameter“.

      Orientieren Sie sich für ein erstes Beispiel an folgender Abbildung.

      Hier im Beispiel wurde H (Height) mit Wert 10 eingetragen.

      Hier im Beispiel wurde H (Height) mit Wert 10 eingetragen.

    2. Bestätigen Sie mit Klick auf Übernehmen.

    3. Legen Sie mit Klick auf jeweils eine neue Zeile an.

    --> Sofort nachdem eine Variable im Variablenmanager angelegt wurde, wird diese auch in der Tabelle angezeigt.

    Variablen H, L und W angelegt

    Variablen H, L und W angelegt

  3. Fügen Sie der Tabelle mittels Zeile hinzufügen weitere Ausprägungen hinzu.

  4. Klicken Sie auf Speichern .

    -> Das Dialogfenster Identifikationsangaben wird mit Registerseite Tabelle geöffnet. Füllen Sie die Pflichtfelder Normbezeichnung, Stücklistenbezeichnung, Normnummer und Norm-Titel aus. Details hierzu finden Sie unter Abschnitt 7.12.7, „Identifikationsangaben“.

    Dialogfenster "Identifikationsangaben" - Registerseite "Tabelle"

    Dialogfenster "Identifikationsangaben" - Registerseite "Tabelle"

    Das Dialogfenster kann jederzeit über Datei-Menü -> Identifikationsangaben oder über geöffnet werden.

    Bestätigen Sie mit Klick auf OK.

    [Hinweis] Hinweis
    • Beachten Sie die Syntax im Feld Normbezeichnung.

    • Das Fenster Identifikationsangaben kann nur über Ok verlassen werden, wenn alle Pflichtfelder ausgefüllt sind.

Nachdem die Tabelle fertig gestellt wurde, wird im nächsten Schritt das 3D-Modell erstellt.

  1. Öffnen Sie hierzu aus PARTproject heraus die 3db-Datei. Die Variablen werden automatisch aus der verknüpften (gleichnamigen) tab/tac-Datei übernommen.

  2. Wählen Sie für alle Variablen, die im Sketch verwendet werden sollen, unter Speicherort die Option In Geometrie und Tabelle. Details hierzu finden Sie unter Abschnitt 7.8.10, „Speicherort: Nur in Geometrie | Nur in Tabelle | In Geometrie und Tabelle“.[62]

    Ansonsten erscheint die Fehlermeldung Unbekannte Variable.

  3. Erstellen Sie basierend auf den angelegten Variablen das 3D-Modell. Eine Kurzinformation hierzu finden Sie unter Abschnitt 7.4, „3D-Modell erstellen: Kleines Beispiel von A bis Z“.



[61] Das passende Beispiel finden Sie im Trainingskatalog im Verzeichnis \v11_news\starting_point_table_or_sketch\cuboid.prj.

[62] Sie erkennen am Farbcode, in welchem Modus eine Variable gespeichert ist:

  • Tabellenvariable

  • Tabellenvariable und Designervariable

  • Designervariable