powered by CADENAS

Manual

Manual

2.5.3. CATIA Makro Interface Installation

Die folgende Makro-Integrationsbeschreibung ist gültig für folgende Versionen:

  • CATIA V5 R24 bis 28 (64 Bit)

  1. PARTsolutions Installation

    Installieren Sie PARTsolutions V11 (z.B. V11SP6).

  2. CADENAS Umgebungsvariable

    Stellen Sie sicher, dass die Umgebungsvariable CADENAS gesetzt ist.

    Öffnen Sie über die Systemsteuerung den Dialogbereich "Umgebungsvariablen". Die CADENAS Umgebungsvariable zeigt, wo die Software installiert ist (lokal).

    Bei einer Standardinstallation wäre dies z.B.:

    C:\Program Files (x86)\cadenas\partsolutions\software
  3. Für CATIA-Schnittstelle benötigte Dateien kopieren

    1. Kopieren Sie die von CADENAS bereitgestellten aktuellen Schnittstellen-Dateien aus dem ..\iface\catia Ordner in das Software-Schnittstellen-Verzeichnis (..iface\catia) Ihrer PARTsolutions Installation.

    2. Kopieren Sie die von CADENAS bereitgestellten aktuellen Konfigurations-Dateien ifcatia.cfg und ifcatiav<5|6>macro.cfg aus dem setup-Verzeichnis in das setup-Verzeichnis Ihrer PARTsolutions-Installation.

  4. CATIA-Umgebungskonfiguration einstellen

    1. Klicken Sie auf Windows Start -> CATIA -> Environment editor, um den Environment Editor zu öffnen.

    2. Klicken Sie Environment -> New, um eine neue Umgebung zu erstellen.

  5. Verknüpfung zu Interface icons erstellen

    Öffnen und editieren Sie folgende Cadenas.txt Datei:

    C:\Users\root\AppData\Roaming\DassaultSystemes\CATEnv\Cadenas.txt

    Der Schlüsselwert von CATGraphicPath muss auf die Schnittstellen-Icons zeigen:

    CATGraphicPath=%CATGraphicPath%;<Schnittstellen-Installationspfad>
     software\iface\catia\VB\resources
  6. PARTsolutions Schnittstellen-Funktionen zu CATIA hinzufügen

    1. Öffnen Sie Ihre CATIA-Umgebung.

    2. Erstellen Sie eine neue Toolbar mit Klick auf View -> Toolbars -> Customize.

    3. Wechseln Sie auf die Registerseite Toolbars.

    4. Klicken Sie auf New....

      -> Das Dialogfenster New Toolbar wird geöffnet.

    5. Tragen Sie unter Toolbar Name den Namen "PARTsolutions" ein.

  7. Macro library zufügen

    1. Klicken Sie auf Tools -> Macro -> Macros....

    2. Klicken Sie auf Macro libraries und dann auf Add existing library. Hier können Sie den Pfad zu den Makros einstellen.

      C:\Program Files (x86)\cadenas\partsolutions\software\iface\catia\VB\V5

  8. Toolbar aktivieren und mit entsprechenden Icons befüllen

    1. Machen Sie einen Rechtsklick auf die Toolbar und klicken Sie im Kontextmenü auf den erstellen Toolbar-Namen (in diesem Fall PARTsolutions).

    2. Klicken Sie im View-Menü auf Toolbars -> Customize.

      -> Dialogfenster Customize wird geöffnet.

    3. Wechseln Sie auf die Registerseite Commands.

    4. Wählen Sie links unter Categories den Punkt Macros.

    5. Wählen Sie rechts unter Commands eines Ihrer Kommandos.

    6. Klicken Sie auf Show Properties....

      -> Der Dialogbereich Command Properties wird geöffnet (Buttonbeschriftung ändert sich auf Hide Properties...).

    7. Tragen Sie unter Title den gewünschten Anzeigenamen der Funktion ein. (Im Bild oben "Replace")

    8. Jetzt können Sie das Kommando aus dem Dialogbereich Categories -> Commands per Drag & Drop auf Ihre Toolbar ziehen.

      -> Das zuvor eingestellte Schnittstellen-Icon wird angezeigt.

Verfügbare Funktionen

Icon

Tooltip

Beschreibung

Einfügen 3D

Start von PARTdataManager und Übernahme von Bauteilen aus PARTsolutions nach CATIA V5.

Ersetzen

Ersetzen eines PARTsolutions-Bauteils gegen ein anderes

GeoSuche

Seamless wird gestartet und eine geometrische Suche wird ausgeführt

[Hinweis] Hinweis

Mit Klick auf einen einzelnen Menüpunkt springen Sie an die passende Stelle der Dokumentation. Zurück zum Ausgangspunkt navigieren Sie per Tastatureingabe Alt + <-.