powered by CADENAS


Manual Avoid additional entries to the existing BOM

In order to avoid that a save in NX or SolidEdge (maybe other Cad systems too) on an existing assembly, that has been created by another cad integration, adds additional entries to the existing BOM (meaning 2 or more occurrences of each entry), please use the following settings.

These entries are preset to NX default and disabled. The entries set their respective NX Session settings to the values needed for correct MultiCAD functionality and restore them immediately after the necessary action is completed. Since these are Session settings, they do not require NX restart and are volatile - get reset to customer defaults with the next session even if the reset by us fails for some reason.


# ...NXOpen::Preferences::SessionPdm::SynchroniseOnSaveTypeComplete : 0 (default)
# ...NXOpen::Preferences::SessionPdm::SynchroniseOnSaveTypeNone : 1

This key can be enabled and set to 1. This will cause NX to not create an additional assembly BOM when one already has been created by another CAD. This will avoid the assembly component duplication issue. This is achieved by setting the SynchroniseOnSave session setting to "None" during the save operation. The CAD interface will still create a BOM when necessary for normal functionality (e.g. when a "foreign" BOM doesn't exist).



This key can be enabled and set to 2 (None). This will cause NX to correctly load assemblies created by the above mentioned save operation (i.e. use its own assembly interpart data, like reference sets and constraints, instead of trying to guess them from the "foreign" BOM). This will ensure that assemblies are loaded correctly during export. However, opening them manually with the option set to the wrong value will still result in a broken assembly, so customers with MultiCAD should really set this setting to 2 in their Customer Defaults.